ClubRalliart.com  
  #1  
Old 10-01-2014, 07:42 PM
p3aker p3aker is offline
Junior Member
 
Join Date: Aug 2014
Posts: 16
Default Weird Sound

Hi Guys,

a few weeks ago, I change my transmission oil and filled it up with PENTOSIN FFL-2.

Now every time i start my car, about three seconds after ignition there's a fairly loud creaking sound coming from under the car (it sounds like something's moving/engaging, not sure exactly where its coming from.. sometimes its at the back, sometimes it sounds like the middle and sometimes it sounds like its coming from the transmission)

but there's no problem with gear shifts.. so I'm a little scared!
Reply With Quote
  #2  
Old 10-01-2014, 08:31 PM
Macky's Avatar
Macky Macky is offline
Administrator
 
Join Date: Oct 2008
Location: SoCal
Posts: 178
Default

that's gonna be hard to diagnose. I would suggest going back to the OEM SST fluid and then checking to see if the sound goes away. these transmissions are known to be finnicky when anything other than the OEM fluid is used.
Reply With Quote
  #3  
Old 10-01-2014, 08:45 PM
p3aker p3aker is offline
Junior Member
 
Join Date: Aug 2014
Posts: 16
Default

Quote:
Originally Posted by Macky View Post
that's gonna be hard to diagnose. I would suggest going back to the OEM SST fluid and then checking to see if the sound goes away. these transmissions are known to be finnicky when anything other than the OEM fluid is used.
again, thanks Macky. haha i was hoping to be a little more clear cut than that.
Reply With Quote
  #4  
Old 10-02-2014, 12:31 PM
Macky's Avatar
Macky Macky is offline
Administrator
 
Join Date: Oct 2008
Location: SoCal
Posts: 178
Default

Eric from Kozmic Motorsports is a known expert in the SST, and he swears by the OEM fluid. he is one of the few extremely knowledgeable people about the SST.

to quote:

Quote:
I think I'm up to 2000 times. SO, my first post on this forum will be 2001. USE ONLY OEM FLUID IN YOUR SST.
To be clear, we don't sell our own oil. We don't recommend any other oil for the SST than the OEM. We don't use any other fluid than the OEM.

Fluid service intervals in the USA are not driven by the needs of the transmission. They are driven by JDPower cost of ownership surveys and the EPA.

Correct interval is as follows.
1st fluid change: After 3500 miles but before 7000 miles (5000 miles prefered).
Each interval after first fluid change 50000 km for street use. 30000km for mixed street/track use. Every season for dedicated track car.

The amount of iron these transmission make during break in is staggering. It tears up valve body bores, solenoid plungers, and fills the balance pistons up with paste.
Reply With Quote
  #5  
Old 10-03-2014, 09:51 AM
iralli_iskustvo's Avatar
iralli_iskustvo iralli_iskustvo is offline
Senior Member
 
Join Date: Jan 2013
Location: Missouri
Posts: 704
Default

I hope its not this sound you speaking of..http://www.evoxforums.com/forums/sho...ACD+pump+issue
__________________
RA - Built head - Built SST - ID1000cc - GTX3576R - GSC S2 cams - GSC beehives/Ti retainers - Timing Chain kit - ARP head studs - AMS fuel rail - AMS Widemouth dp - TurboXS exhaust - DrivenFab oil catch can - MAP oil pan - MAP cast manifold - AEM wideband - COBB 3 port EBCS - Tial QRJ - Sakura 3.5 intake - Kozmic Walbro 450 fuel pump - Depo Racing fmic/licp - TS engine/exhaust mounts - Cusco bar - D2 RS coil - Megan Racing control arms/toe - Whiteline sway bars - Brembo 6 piston


Tuned by TJ
Reply With Quote
  #6  
Old 10-03-2014, 11:36 AM
Markspd6's Avatar
Markspd6 Markspd6 is offline
Regional Moderator
 
Join Date: Aug 2011
Location: CYPRESS,CA
Posts: 1,067
Default

Yeah the real bitch is when you check you Manual, it says nothing about doing an oil swap early on, it says 60k(i think) and apparently, that's not correct, but I'm sure the dealers would get lots of crap and wouldn't sell as many cars if they recommended changing the oil that often.
__________________
Ralliart/EVO rear fender rolls and tab grinding $100, guaranteed fitment(when possible, you should always do the fitment research first)

minimal partial rolls $60(no tab grinding)

So cal fender roller rental $10 per day(3 day min) with $200 cash deposit. Includes Eastwood fender roller, heat gun and heavyweight carry bag.
Reply With Quote
  #7  
Old 10-04-2014, 12:38 AM
p3aker p3aker is offline
Junior Member
 
Join Date: Aug 2014
Posts: 16
Default

Quote:
Originally Posted by iralli_iskustvo View Post
I hope its not this sound you speaking of..http://www.evoxforums.com/forums/sho...ACD+pump+issue
No, nothing like that (thank god)

mines a one off thing (every time you start the car) and it sounds like something metal is engaging in place but it doesn't sound so healthy, like i said its about 3 seconds after i start the car.. so would any of you what happens to activate within that time frame. AWD pump ? would that make such a sound. I guess i can record it.


also i happened to hear another noise last night, i can only hear it when i have the wheel turned (e.g taking a slight corner or merging lanes) and i accelerate, sounds like somethings engaging again.

any thoughts boys ?
Reply With Quote
  #8  
Old 10-04-2014, 12:59 AM
p3aker p3aker is offline
Junior Member
 
Join Date: Aug 2014
Posts: 16
Default

Quote:
Originally Posted by Macky View Post
Eric from Kozmic Motorsports is a known expert in the SST, and he swears by the OEM fluid. he is one of the few extremely knowledgeable people about the SST.

might bite the bullet and buy some queen

Last edited by p3aker; 10-04-2014 at 01:08 AM.
Reply With Quote
Reply

Tags
oil, sounds, transmission

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:13 AM.




Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright (c) 2011 RnD Media LLC