ClubRalliart.com  
  #1  
Old 03-25-2014, 03:43 PM
bttmotorsport.com bttmotorsport.com is offline
Junior Member
 
Join Date: Jan 2014
Location: Cape Coral, FL
Posts: 9
Default Ralliart at 100 AW Rally

Few months buiding time turned out to be way too short, at least with minimum knowledge of "modern" car with way too much complicated electronics...
Got the car running though just few days before Rally AmericaŽs second round of 2014 championship series, absolutely zero testing before 1st stage.
Turned out that ACD was not working, so car was mainly fwd, with just enough 4wd to make things really complicated...
Transmission overheating problems with continous limp modes forced us to retire on 14th stage, but we managed to take 3rd Place on regional Open class on Friday.
If interested, go and check few incars:
https://www.youtube.com/watch?v=qgo4...SUAIF2LqQ59MDw
https://www.youtube.com/watch?v=i09L...SUAIF2LqQ59MDw
Slowly... and not steady.. But weŽll be back.
Reply With Quote
  #2  
Old 03-25-2014, 07:05 PM
Jackal's Avatar
Jackal Jackal is offline
Senior Member
 
Join Date: Jun 2010
Location: Winnipeg, Manitoba ,Canada
Posts: 1,283
Default

Looks like fun!
__________________
Instagram #Evosoulralliart 1/4 mile @ 12.7 seconds @ 104 MPH.
Too fricken much to list. Check out my build thread http://clubralliart.com/showthread.php?t=1066
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:37 AM.




Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright (c) 2011 RnD Media LLC