ClubRalliart.com  
  #1  
Old 03-20-2016, 03:06 PM
RalliEvo RalliEvo is offline
Junior Member
 
Join Date: Mar 2016
Location: Rhode Island
Posts: 2
Default Do I need a rebuild?

Background
2011 Ralliart
Roughly 103k
Mods: AEM intake, CXRacing intercooler with piping & bov, and a Cobb 3 port


So my SES light came on yesterday right before i headed on a 3 hour round trip to pick up a downpipe. No issues driving with light on. Scanned the code this morning and pulled a U0100 chassis code and a P1871 transmission code.

According to my scanner thats a manufacture specific code. Obd-data website says its a "Undefined Gear Ratio" code Transmission mechanical transfer case 4x4 switch circuit short to battery. (P1871)

Code U0100 is a "Lost Communication with ECM/PCM A"

Cleared it hoping it was just a false alarm but the codes came back after a drive around town. Do i need a rebuild or can it be saved?
Reply With Quote
  #2  
Old 03-20-2016, 08:11 PM
RalliEvo RalliEvo is offline
Junior Member
 
Join Date: Mar 2016
Location: Rhode Island
Posts: 2
Default

Okay, did some digging and found that OBD website gave me wrong info on code P1871. Code P1871 is APS System (Signal Abnormality) Step one is to check all CAN Bus connections.. Any idea how i can do that with a usb to OBD or tactrix openport?

But wait it gets better! Step three is replace transmission assembly (smiley poop emoji)

If it does come down to that im erasing the code at a dealership and trading her in...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:19 AM.




Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright (c) 2011 RnD Media LLC